Back to overview
Degraded

Frequent DDoS Attacks

Oct 08 at 04:19pm MST
Affected services
Website
EdgyPro Menu

Resolved
Oct 11 at 05:37pm MST

We have updated our DDoS protection and have mitigated the active attacks.

Created
Oct 08 at 04:19pm MST

We have received multiple DDoS attacks in the last few days which forced us to increase our security. This requires a full EdgyPro re-installation and for you to clear your browser cache to remove all old cached versions of EdgyPro off of your device.

We have been working hard with support from our server host providers and support from Cloudflare to prevent future DDoS attacks but it has been difficult to balance the security without messing up the user experience for real users.